Pi’s Blog

My blog about Thunderbird and GSoC 2008

Thunderbird 2 Support

I recently decided to support Thunderbird 2 (specifically 2.0.0.14 and above), but only had basic sync support (only the original attributes were synced) until figuring out a few bugs today.  As of now, the extension fully supports Thunderbird 2, 3, and 3 with the patch for Bug 413260 applied.  The only catch is that the extra attributes added by the extension (like Third and FourthEmail, different types of screennames, etc.) are only editable after the card has been created.  You cannot make a new card and set those attributes right away due to how the address book works before the refactoring in Bug 413260 is applied.  It detects the version and whether 413260 is applied when it starts, so the same extension will work with whatever version you have installed between 2.0.0.14 and 3.0a2.

Over the next week I plan on testing the features of the extension and fixing any bugs that appear.  When this is done, I will hopefully be able to release an alpha version for public use.  If you do decide to use it, I strongly suggest backing up all of your Google Contacts and your entire Thunderbird profile.  You can find info on backing up your Google Contacts here and info on backing up your profile here.

Edit: There is another problem without the patch from Bug 413260 applied.  Copying a card will not copy over the added attributes.

Advertisements

July 19, 2008 - Posted by | GSOC | , ,

No comments yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: